KB: Outlook app reports “Already Workplace Joined” when trying to register an Android device with Azure AD

Symptoms

On a phone that is running Android with the Outlook app and Intune Company Portal installed, you attempt to set up a user account within Outlook to access Exchange Online.

Outlook prompts you to Register the device with Azure AD as you also have an Intune App Protection – Conditional Access policy applied to the user. The Outlook app then errors with “Already Workplace Joined” and you cannot set up the user account. You check Azure AD but the device does not exist there so it cannot be deleted.

Cause

The symptom can be reproduced with this process:

  • Take an Android phone not enrolled with MDM or registered with Azure AD
  • Install the Outlook App and Intune Company Portal App on the phone
  • Apply an Intune App Protection – Conditional Access policy within the new Azure portal to two different users enabled for Exchange Online
  • Open Outlook on the phone and set up the account for User 1
  • Outlook will prompt you to Register the device with Azure AD as shownJoin_01
  • Complete the Outlook account set up
  • Delete the account for User 1 from the Outlook app
  • Open the new Azure AD portal and delete the registered device for User 1 using the process shown:
  • Open the Users and groups bladeDelete_01
  • Click on User 1 and open the Devices section to show the registered device.Delete_02
  • Select the button and click DeleteDelete_03
  • Go back to the phone and set up an account for User 2 in the Outlook app
  • Outlook will prompt you to Register the device with Azure AD againJoin_01
  • When you click Register you will get the following errorsJoin_Error_01 Join_Error_02

The deletion of the device in Azure AD causes the Outlook app to prompt for re-registration, as it should, however for some reason this process fails when attempting to re-register for a different user on the same phone.

Resolution

The resolution that worked for me was to un-install and re-install the Intune Company Portal app. I also tried clearing cache and app data for the Outlook app and Intune Company Portal app, and waiting 2 days to see if it was a delay in deletion of the device inside Azure but those didn’t work.

 

 

 

2 thoughts on “KB: Outlook app reports “Already Workplace Joined” when trying to register an Android device with Azure AD

Leave a reply to sanguy Cancel reply